diff mbox series

thermal/debugfs: replace kzalloc() with kcalloc() in thermal_debug_tz_add()

Message ID 20250222-thermal_kcalloc-v1-1-9f7a747fbed7@ethancedwards.com
State New
Headers show
Series thermal/debugfs: replace kzalloc() with kcalloc() in thermal_debug_tz_add() | expand

Commit Message

Ethan Carter Edwards Feb. 22, 2025, 8:02 p.m. UTC
We are trying to get rid of all multiplications from allocation
functions to prevent integer overflows[1]. Here the multiplication is
obviously safe, but using kcalloc() is more appropriate and improves
readability. This patch has no effect on runtime behavior.

Link: https://github.com/KSPP/linux/issues/162 [1]
Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Ethan Carter Edwards <ethan@ethancedwards.com>
---
 drivers/thermal/thermal_debugfs.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


---
base-commit: 5cf80612d3f72c46ad53ef5042b4c609c393122f
change-id: 20250222-thermal_kcalloc-881dcf5b77b8

Best regards,
diff mbox series

Patch

diff --git a/drivers/thermal/thermal_debugfs.c b/drivers/thermal/thermal_debugfs.c
index c800504c3cfe0ea3b4a51286f348dd5802e1898f..60ee6c366998e26447a0b985112f578ba8757f17 100644
--- a/drivers/thermal/thermal_debugfs.c
+++ b/drivers/thermal/thermal_debugfs.c
@@ -876,7 +876,7 @@  void thermal_debug_tz_add(struct thermal_zone_device *tz)
 
 	tz_dbg->tz = tz;
 
-	tz_dbg->trips_crossed = kzalloc(sizeof(int) * tz->num_trips, GFP_KERNEL);
+	tz_dbg->trips_crossed = kcalloc(tz->num_trips, sizeof(int), GFP_KERNEL);
 	if (!tz_dbg->trips_crossed) {
 		thermal_debugfs_remove_id(thermal_dbg);
 		return;